Repository was unable to access the Registry & SOAP error

Jul 22, 2008 at 10:04 AM
Edited Jul 23, 2008 at 3:23 AM

I have two questions.

First, I ran Provide and Register using the Test Harness in the 18637 version.
I modified all .map files and app.config. The smoke tests of Registry and Repository are ok. Port number are 8080 for registry & repository.
However, there was a error shows bellow:

<tns:RegistryResponse status="urn:oasis:names:tc:ebxml-regrep:ResponseStatusType:Failure" xmlns:tns="urn:oasis:names:tc:ebxml-regrep:xsd:rs:3.0" xmlns:rim="urn:oasis:names:tc:ebxml-regrep:xsd:rim:3.0"><tns:RegistryErrorList highestSeverity=""><tns:RegistryError codeContext="Repository was unable to access the Registry." errorCode="XDSRegistryNotAvailable" severity="urn:oasis:names:tc:ebxml-regrep:ErrorSeverityType:Error" /></tns:RegistryErrorList></tns:RegistryResponse>
Second, I ran all tests except Provide and Register and Retrieve Document Set in the Test Harness.
There will be an error meeages:

Cannot process the message because the content type 'multipart/related; type="application/xop+xml";start="<



Sep 29, 2008 at 8:58 AM
The problem in the second problem you mentioned is that the binding between the client (TestHarness) and the server (XDS reg/rep) is in a mismatch.
The Xds registry is configured to "Text" message encoding while the TestHarness is configure to use "Mtom".

Please change all message encodings to "Mtom" e.g. in XDSRegistryServiceHost\app.config. Look for messageEncoding="Text" and replace it with messageEncoding="Mtom".

Kind regards,
Piet-Hein Heemskerk
GE Healthcare

Oct 1, 2008 at 10:45 PM
Piet answer is correct, apart from one detail:

XDSRegistry should be communicating using SOAP instead of MTOM+XOP, so the configs are:

1) Keep the messageEnconding="Text" in the ReigstryServiceHost app.config
2) On the client applications (in this case the test harness when you're running the register document set and the Repository when you're running the Provide and Register Document Set) the messageEnconding value for the client endpoints pointing to XDSRegistry service should also use "Text".

Probably the easiest way to do this is to change the configurations for the Registry Service and update the web references on both the Repository and the Test Harness. After this everything should be ok.

Cheers, Wagner.
Oct 8, 2008 at 4:19 AM
Thenaks very much,
Problem solved, I changed the messageEnconding="Text" in client's
But another problem was occured.
It is life.

Best regards,

May 25, 2010 at 10:54 AM

Can anybody answer the first question as I am facing the same problem.

Thanks n Regards


May 25, 2010 at 9:12 PM

You aslo need to mofify the config: source\IHE\RepositoryProfile\app.config. Please check it.

Oct 29, 2010 at 4:39 PM

I got the same first error. Does it have something to do with adding service references to .map files in testharness? I couldn't find "add service reference" so I did "add web reference" to repository and registry service. It didn't work.